通达信六脉神剑指标战法,六脉神剑指标参数设置

Q1:谁有同花顺的六脉神剑指标公式?

DIFF:=EMA(CLOSE,8)-EMA(CLOSE,13);
DEA:=EMA(DIFF,5);
DRAWICON(DIFF>DEA,1,7);
DRAWICON(DIFF<DEA,1,8);
DRAWTEXTabs(0,70,'.MACD'),COLORFFFFFF;
A1:=DIFF>DEA;
MACDX:IF(A1,1,0),COLORRED;
RSV1:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
DRAWICON(K>D,2,7);
DRAWICON(K<D,2,8);
DRAWTEXTabs(0,59,'.KDJ'),COLORFFFFFF;
A2:=K>D;
KDJX:IF(A2,2,0),COLORRED;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
DRAWICON(RSI1>RSI2,3,7);
DRAWICON(RSI1<RSI2,3,8);
DRAWTEXTabs(0,47,'.RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSIX:IF(A3,3,0),COLORRED;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
DRAWICON(LWR1>LWR2,4,7);
DRAWICON(LWR1<LWR2,4,8);
DRAWTEXTabs(0,35,'.LWR'),COLORFFFFFF;
A4:=LWR1>LWR2;
LWRX:IF(A4,4,0),COLORRED;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
DRAWICON(CLOSE>BBI,5,7);
DRAWICON(CLOSE<BBI,5,8);
DRAWTEXTabs(0,23,'.BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
BBIX:IF(A5,5,0),COLORRED;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
DRAWICON(MMS>MMM,6,7);
DRAWICON(MMS<MMM,6,8);
DRAWTEXTabs(0,11,'.MTM'),COLORFFFFFF;
A6:=MMS>MMM;
MTMX:IF(A6,6,0),COLORRED,LINETHICK2;
涨买入:IF((A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,7,0),COLORYELLOW,LINETHICK1;
上涨:IF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,7,0),COLORYELLOW,LINETHICK1;
晴天:last(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX=21),LINETHICK0;
雨天:last(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX>0 AND MACDX+KDJX+RSIX+LWRX+BBIX+MTMX<21 ),LINETHICK0;
雪天:last(MACDX+KDJX+RSIX+LWRX+BBIX+MTMX=0),LINETHICK0

Q2:求同花顺的六脉神剑指标

{参数:N1(1,360,3) N2(1,360,5) N3(1,360,8) N4(1,360,13) N5(1,360,21) N6(1,360,34)} DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4); DEA:=EMA(DIFF,N2); DRAWICON(DIFF>DEA,1,1); DRAWICON(DIFF<DEA,1,2); DRAWTEXT(ISLASTBAR=1,1,'.MACD'),COLORFFFFFF; A1:=DIFF>DEA; RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100; K:=SMA(RSV1,N1,1); D:=SMA(K,N1,1); DRAWICON(K>D,2,1); DRAWICON(K<D,2,2); DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORFFFFFF; A2:=K>D; LC:=REF(CLOSE,1); RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100; RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100; DRAWICON(RSI1>RSI2,3,1); DRAWICON(RSI1<RSI2,3,2); DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF; A3:=RSI1>RSI2; RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100; LWR1:=SMA(RSV,N1,1); LWR2:=SMA(LWR1,N1,1); DRAWICON(LWR1>LWR2,4,1); DRAWICON(LWR1<LWR2,4,2); DRAWTEXT(ISLASTBAR=1,4,'.LW&R'),COLORFFFFFF; A4:=LWR1>LWR2; BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4; DRAWICON(CLOSE>BBI,5,1); DRAWICON(CLOSE<BBI,5,2); DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF; A5:=CLOSE>BBI; MTM:=CLOSE-REF(CLOSE,1); MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1); MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3); DRAWICON(MMS>MMM,6,1); DRAWICON(MMS<MMM,6,2); DRAWTEXT(ISLASTBAR=1,6,'.ZLMM'),COLORFFFFFF; A6:=MMS>MMM; (A1 AND A2 AND A3 AND A4 AND A5 AND A6),COLORFFFF00; 涨不停买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6=1 AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1)=0,COLORFFFF00; DRAWICON(DIFF>DEA,1,1); DRAWICON(DIFF<DEA,1,2); DRAWICON(K>D,2,1); DRAWICON(K<D,2,2); DRAWICON(RSI1>RSI2,3,1); DRAWICON(RSI1<RSI2,3,2); DRAWICON(LWR1>LWR2,4,1); DRAWICON(LWR1<LWR2,4,2); DRAWICON(CLOSE>BBI,5,1); DRAWICON(CLOSE<BBI,5,2); DRAWICON(MMS>MMM,6,1); DRAWICON(MMS<MMM,6,2); 7,COLORWHITE;{防止显示字符不全,可不用};

Q3:通达信指标公式交流分享

哦,我路过的,了解!

Q4:下面是通达信六脉神剑的选股公式,请问如果连续四天都满足以下条件,公式该怎么写完整,谢谢!

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV1,3,1);
D:=SMA(K,3,1);
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),5,1))/(SMA(ABS(CLOSE-LC),5,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),13,1))/(SMA(ABS(CLOSE-LC),13,1))*100;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13))*100;
LWR1:=SMA(RSV,3,1);
LWR2:=SMA(LWR1,3,1);
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,5),3)/EMA(EMA(ABS(MTM),5),3);
MMM:=100*EMA(EMA(MTM,13),8)/EMA(EMA(ABS(MTM),13),8);
A6:=MMS>MMM;
QQ:=(A1 AND A2 AND A3 AND A4 AND A5 AND A6) AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6,1);
涨买入:EVERY(QQ,4);

Q5:淘宝的六脉神剑法则

《六脉神剑》指标源码
1、本指标由经久不衰的六项经典指标组成,MACD,KDJ,RSI,LW&R,BBI及ZLMM。
2、当某指标出现金叉,拐点画一个买入红箭头。当某指标出现死叉,拐点画一个卖出绿箭头。
3、红箭金叉趋势向上,绿箭死叉预示趋势向下。当六项指标同时发出红箭头时买入待涨,也就是投资回报大于投资付出!反之亦然,趋势一目了然!
4、出现多于三个向上的红箭头,表示趋势转强!向上的箭头越多,趋势越强!
5、出现多于三个向下的绿箭头,表示趋势转弱!向下的箭头越多,趋势越弱!

Q6:股票指标公式

六脉神剑:
丹田能量:EMA(C,55)COLORMAGENTA,CIRCLEDOT;
少商剑:EMA(C,13),COLORRED,LINETHICK2;
商阳剑:EMA(EMA(C,13),2);
中冲剑:EMA(EMA(EMA(C,13),2),2);
关冲剑:EMA(EMA(EMA(EMA(C,13),2),2),2);
少冲剑:EMA(EMA(EMA(EMA(EMA(C,13),2),2),2),2);
少泽剑:EMA(EMA(EMA(EMA(EMA(EMA(C,13),2),2),2),2),2);
IF(少商剑<REF(少商剑,1),少商剑,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(商阳剑<REF(商阳剑,1),商阳剑,DRAWNULL),COLORYELLOW;
IF(中冲剑<REF(中冲剑,1),中冲剑,DRAWNULL),COLORYELLOW;
IF(关冲剑<REF(关冲剑,1),关冲剑,DRAWNULL),COLORYELLOW;
IF(少冲剑<REF(少冲剑,1),少冲剑,DRAWNULL),COLORYELLOW;
IF(少泽剑<REF(少泽剑,1),少泽剑,DRAWNULL),COLORYELLOW;
坐轿子:
VAR1:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
STICKLINE(控盘<0,控盘,0,1,0),COLORWHITE;
A10:=CROSS(控盘,0);
无庄控盘:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
开始控盘:IF(A10,5,0),LINETHICK1,COLORYELLOW;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLORRED;
有庄控盘:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1,0),COLORFF00FF;
高度控盘:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1,0),COLOR00FF00;
主力出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;